SQL 2014 Issues

Jul 7, 2014 at 3:49 PM
I have been using your product and love it. We recently deployed some 2014 SQL Servers that the product does not run against. The SqlServerVersion namespace is not working. I updated the Microsoft.SqlServer.SMO.dll and added a reference. However, now when I compile I get the error below. Any ideas on how to get the references resolved?

1>C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1605,5): warning MSB3247: Found conflicts between different versions of the same dependent assembly.
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : error CS1705: Assembly 'Microsoft.SqlServer.Smo, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' uses 'Microsoft.SqlServer.ConnectionInfo, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' which has a higher version than referenced assembly 'Microsoft.SqlServer.ConnectionInfo, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91'
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : error CS1705: Assembly 'Microsoft.SqlServer.Smo, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' uses 'Microsoft.SqlServer.Management.Sdk.Sfc, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' which has a higher version than referenced assembly 'Microsoft.SqlServer.Management.Sdk.Sfc, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91'
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : error CS1705: Assembly 'Microsoft.SqlServer.Smo, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' uses 'Microsoft.SqlServer.SqlEnum, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' which has a higher version than referenced assembly 'Microsoft.SqlServer.SqlEnum, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91'
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
1>c:\Program Files (x86)\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll : warning CS1684: Reference to type 'Microsoft.SqlServer.Management.Smo.DelayedDurability' claims it is defined in 'c:\Program Files (x86)\Microsoft SQL Server\110\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll', but it could not be found
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========
Dec 12, 2014 at 6:36 PM
Having the same issue, would love to be able to use with SQL 2014
Mar 30, 2016 at 12:46 AM
Is it possible to get a release for SQL 2014?
Mar 30, 2016 at 2:02 AM
Click the github link on the Home page and that will take you to a version that supports SQL 2014.